Mattermost, Inc.

Current desktop client build won't build

Hi,

I’m trying to build the current desktop app, but I keep getting an exit error. Getting the following errors and warning. Can you tell me how to resolve this please?

121 warn mattermost-desktop@1.1.0 No repository field.
122 verbose stack Error: mattermost-desktop@1.1.0 postinstall: npm run build
122 verbose stack Exit status 1
122 verbose stack at EventEmitter. (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:239:16)
122 verbose stack at emitTwo (events.js:100:13)
122 verbose stack at EventEmitter.emit (events.js:185:7)
122 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:24:14)
122 verbose stack at emitTwo (events.js:100:13)
122 verbose stack at ChildProcess.emit (events.js:185:7)
122 verbose stack at maybeClose (internal/child_process.js:850:16)
122 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
123 verbose pkgid mattermost-desktop@1.1.0
124 verbose cwd /Users/girv/projects-www/insity.me/desktop-master
125 error Darwin 15.4.0
126 error argv “/usr/local/Cellar/node/5.10.1/bin/node” “/usr/local/bin/npm” "install"
127 error node v5.10.1
128 error npm v3.8.3
129 error code ELIFECYCLE
130 error mattermost-desktop@1.1.0 postinstall: npm run build
130 error Exit status 1
131 error Failed at the mattermost-desktop@1.1.0 postinstall script ‘npm run build’.
131 error Make sure you have the latest version of node.js and npm installed.
131 error If you do, this is most likely a problem with the mattermost-desktop package,
131 error not with npm itself.
131 error Tell the author that this fails on your system:
131 error npm run build
131 error You can get information on how to open an issue for this project with:
131 error npm bugs mattermost-desktop
131 error Or if that isn’t available, you can get their info via:
131 error npm owner ls mattermost-desktop
131 error There is likely additional logging output above.
132 verbose exit [ 1, true ]

Hi, could you try removing node_modules and using v1.1.1 or the latest source? I had found that some dependencies had little breaking changes at latest version, so npm run build fails.