Mattermost, Inc.

“Connecting ...” does not disappear in the iPhone app

When I launch the Mattermost app for iOS, “Connecting …” continues to appear under the header. On the right side, a progress circle continues to rotate.

At this time, the channel itself is updated as usual. I get a notification and a badge when a new comment is posted. However, there is a problem when touching the iOS notification center. The app crashes with a high probability.

This has continued since Mattermost was around 5.11. The app itself has also been updated twice, and is currently version 1.22.1 (build 225). I have updated Mattermost to 5.14.0.
What’s strange to me here is 5.13.0(build 5.13.2) when I look at the Mattermost version on iOS.When I access Mattermost on a PC or smartphone web browser, 5.14.0 is displayed. And I ran “Delete Documents and Data” from the iOS app settings. Then the display changed to 5.14.0.
However, this “Connecting …” will not disappear.

Is there a solution to this?

Hi @Babbles, please take a look at this troubleshooting doc as a start: https://docs.mattermost.com/mobile/mobile-troubleshoot.html#i-see-a-connecting-bar-that-does-not-go-away.

I reviewed the nginx configuration. In the first place, I didn’t change Mattermost’s own nginx.
Currently, this bar(Connecting…) is not displayed when accessing with a web browser on a PC or smartphone. This display is only for iOS app.

What are the remaining settings I should doubt?

My environment: CentOS 7.6, Nginx 1.16.1

Hi @Babbles, can you check and make sure that Websocket support is installed and enabled on your IIS server?
You can find the steps to enable it here: https://docs.microsoft.com/en-us/iis/configuration/system.webserver/websocket#windows-server-2012-or-windows-server-2012-r2
They’re outlined for Windows Server 2012, but shouldn’t be too different in newer versions.

I’m sorry, I’m not completely sure. I don’t think Windows IIS is used on my server.

I tried “Mattermost Classic” app on same iPhone. This will not display this bar. I think there is a problem with the iOS app. Is it the server side?

Hi, @Babbles

I came across a couple of articles where a user was able to have this issue ironed out after configuring the AllowCorsFrom: "*" setting in the config file based on the documentation below.

Can you please give it a try and verify if it works on your end?

If I set AllowCorsFrom to blank or *, the bar disappeared.

1 Like