Mattermost, Inc.

Coming soon: Ending Support for PostgreSQL v9.4

PostgreSQL ended long-term support for version 9.4 in February. Mattermost will officially be supporting Postgres version 10 with the Mattermost v5.26 release, which will be released in August 16, 2020. New installs will require Postgres version 10. Previous Mattermost versions, including our current Extended Support Release, will continue to be compatible with PostgresSQL version 9.4. We plan on fully deprecating PostgreSQL 9.4 in our v6.0 release (date to be announced).

We highly recommend upgrading to PostgresSQL version 10+ after August. Please follow the instructions under the Upgrading Section within the PostgreSQL documentation.

Questions or concerns?

Let us know by replying to this forum post.