Mattermost Peer-to-Peer Forum

Changing display language has no effect


#1

Summary

Changing display language has no effect

Steps to reproduce

Mattermost Version: 5.4.0 on Ubuntu 18.04
The configuration has locale de as default and offers de and en as options.

Expected behavior

Switching in the account settings should switch the language. New signups should see Mattermost in de locale.

Observed behavior

Everything remains consistently in locale en. No indication of trouble in the logs.

I have no idea where to look for solving this.

I also created an SO question on this: https://stackoverflow.com/questions/53459887/changing-display-language-has-no-effect-in-mattermost


#2

Hi @verallgemeinung,

Just to confirm, did you perform a server restart after changing the config settings? Or is this is a new issue after upgrading to v5.4?


#3

I have restarted the mattermost service. This did not occur after upgrading. I did a fresh install.


#4

Hello, @verallgemeinung.

I noticed that from the post you had on StackOverflow, you provided an update there:

Both test users had the ‘en’ locale in the database. Changing the db by hand had the desired effect

Thought that it would also be a good idea to include it here. In this case, can you confirm that you had to manually modify the locale to de in the database and does the change persisted after you rebooted the server?


#5

Thanks for including that here, I missed to do that.

I confirm that I manually updated the locale column in the users table. The change persists after restarting the mattermost service.