Mattermost, Inc.

Change the mattermost front end

Hi everyone,
I am trying to change front end by forking the platform repo. I am able to deploy it on my local machine.But when i make changes to the jsx file, they are not reflected on the browser.I have tried restarting the server. But still the same issue. Please share how can i resolve it.

If you’re using nginx like described in the installation instructions(https://docs.mattermost.com/install/install-rhel-66.html#configuring-nginx-as-a-proxy-for-mattermost-server), its very likely you’re suffering from the caching.

For development, where you need to actively view changes, I suggest you disable any form of caching from your nginx virtual host by commenting the following lines(assuming you followed the mattermost installation guide):

proxy_cache_path /var/cache/nginx levels=1:2 keys_zone=mattermost_cache:10m max_size=3g inactive=120m use_temp_path=off;
proxy_cache mattermost_cache;
proxy_cache_revalidate on;
proxy_cache_min_uses 2;
proxy_cache_use_stale timeout;
proxy_cache_lock on;

To comment those line simple add a # in front of it.

In addition you could do a forced clear on the cache by running:

find /var/cache/nginx/ -type f -delete
service nginx reload

As you can see above on the config your cache patch was set at:

proxy_cache_path /var/cache/nginx

Which is why I use /var/cache/nginx on the find+delete procedure.

Hi @raminder,

After starting the server and then running make restart-client, do you see webpack outputting a bunch of information about different files?