Cant Use S3 Storage


#1

Hi all,

I’m using MM v5.0.1. I’m trying to setup S3 bucket storage.

I’ve created a S3 bucket and a IAM role to give read/write permissions.

I can access the storage in the server.

Then I try to setup S3 in MM but test connection always fails.

It returns “Connection Unsuccessful:S3 Bucket is required - undefined”

What’s does it mean?

Cheers


#2

Hi @RbDev! Would you be able to share your config settings for S3?


#3

I’m using admin console >> storage.
Enabled type Amazon S3, typed the bucket name and pressed test connection.
Are there settings required in the config?


#4

Hi @RbDev! Can you help take a look at step 6 on this doc to see if it helps, e.g. there is a note about having enough free space: https://docs.mattermost.com/install/config-mattermost-server.html.

Can you also help take a look at this thread with some tips for troubleshooting: https://github.com/mattermost/mattermost-server/issues/8714?

If these don’t help, just let me know and I’ll ask an engineer to continue to troubleshoot.


#5

The first link doesn’t help. it lacks important steps. I think processes like setting up S3 storage must be well documented on docs.mattermost.org.

"
If you store the files on Amazon S3, set File Storage System to Amazon S3 and enter the appropriate values for your Amazon account.
"

The second link seems to be a different issue.

The s3 test error I keep getting is the following

{“level”:“error”,“ts”:1531504348.024893,“caller”:“web/handlers.go:140”,“msg”:“S3 Bucket is required”,“path”:"/api/v4/file/s3_test",“request_id”:“hbcgfgtofighxdyy9aanjo9uac”,“ip_addr”:“XX.XX.XX.XX”,“user_id”:“m8fp1td76tbi5ctaonm5tm5zko”,“method”:“POST”,“err_where”:“S3File”,“http_code”:400,“err_details”:""}


#6

@jespino Would you know what might be causing issues with setting up S3 bucket storage?

Summary:

RbDev has created an S3 bucket and a IAM role to give read/write permissions but he gets an error saying “Connection Unsuccessful:S3 Bucket is required - undefined”. This is the full error:

{“level”:“error”,“ts”:1531504348.024893,“caller”:“web/handlers.go:140”,“msg”:“S3 Bucket is required”,“path”:"/api/v4/file/s3_test",“request_id”:“hbcgfgtofighxdyy9aanjo9uac”,“ip_addr”:“XX.XX.XX.XX”,“user_id”:“m8fp1td76tbi5ctaonm5tm5zko”,“method”:“POST”,“err_where”:“S3File”,“http_code”:400,“err_details”:""}


#7

Hi @RbDev, could you configure S3, save all changes, and then click the “Test button”? The test button now is working with the already saved configuration. It’s a bug, that must be solved, but for now the “save and then test” approach should work.