Mattermost, Inc.

Can't start mattermost after upgrading from 3.6.2 to 3.8.2

Hi Guys,

I can not start mattermost after upgrading to 3.7.2.
The error message when i try to check version of new upgraded.
Thanks for any advices.

 ./platform version

Version: 3.7.0
Build Number: 3.7.2
Build Date: Fri Mar 17 19:07:10 UTC 2017
Build Hash: f4473cf312d09a53a57312745963aee334e251cb
Build Enterprise Ready: false
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x419478]

goroutine 1 [running]:
panic(0xc72560, 0xc4200100b0)
/usr/local/go/src/runtime/panic.go:500 +0x1a1
main.printVersion()
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/cmd/platform/version.go:29 +0x428
main.versionCmdF(0x1149360, 0x116ff38, 0x0, 0x0)
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/cmd/platform/version.go:20 +0x30
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).execute(0x1149360, 0x116ff38, 0x0, 0x0, 0x1149360, 0x116ff38)
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:647 +0x443
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0xc420078900, 0x0, 0x0, 0x0)
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:734 +0x367
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).Execute(0xc420078900, 0xc4200fa650, 0xb)
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:692 +0x2b
main.main()
/home/ubuntu/workspace/msr/platform-release/src/github.com/mattermost/platform/cmd/platform/mattermost.go:50 +0x49f

Hi,

It only works if I sudo su - <mattermostuser> and run ./bin/platform -version from inside the mattermost install folder.

me@server:~$ sudo su - mmost
[sudo] password for me:
mmost@server:~$ /opt/mattermost/bin/platform -version
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x8 pc=0x581c4c]

(...)

me@server:~$ sudo su - mmost
[sudo] password for me:
mmost@server:~$ cd /opt/mattermost
mmost@server:/opt/mattermost$ bin/platform -version
Version: 3.7.0
Build Number: 3.7.2
(...)

Happens on both 3.6.2 and 3.7.0.

Hi bakoo,

Thanks for your advice,
but it did not work with mine.

I wonder about error message.
because my env. have no directory as “…/go/src…” and "…/workspace/…"
some thing wrong with release image ?

  1. What database (and database version) are you using?
  2. What version of Mattermost were you upgrading from?

Also, could you please provide the contents of your mattermost logs for when you tried to run the server and this crash happened?

I upgraded mattermost_3.6.2 to 3.7.2
DB: Postgres 9.3
When i tried to start mattermost, the process of platform did not up.
When i test to run ./mattermost/bin/platform version, i got message as above.

And now, I tried to upgrade mattermost_3.6.2 to 3.8.2,
when i test to run
sudo ./mattermost/bin/platform version
i got message as following:
utils.config.load_config.opening.panic

of course, it’s working fine when i revert to ver.3.6.2 at same environment !

What happen with new release of mattermost ?

Nobody have ideas ?

Could you please paste the full output from when you tried to start mattermost?

Just want to clear something out, the panic message information, is about the compilation of that given mattermost build you’re using, so the path seeing there are the paths from the machine it was compiled at(thus it may not match your machine paths at all and that is completely normal) and bear no meaning to anyone other than core devs/devs to pin point the issue, as you can see it tells the tree of files and lines where the issue happens.