We're Hiring!

Mattermost, Inc.

Can't save configuration from system console

When logged in to the system console I can’t save any changes: get the error
“An error occurred saving the configuration”

Error log:
{“level”:“error”,“ts”:1605716675.272129,“caller”:“mlog/log.go:229”,“msg”:“Plugin failed to ServeHTTP, muxBroker couldn’t Accept request body connection”,“plugin_id”:“github”,“error”:“timeout waiting for accept”}
{“level”:“error”,“ts”:1605716762.0308871,“caller”:“mlog/log.go:229”,“msg”:“Plugin failed to ServeHTTP, RPC call failed”,“plugin_id”:“github”,“error”:“connection is shut down”}

Running Enterprise Edition 5.28

Hello, @matttbc

Can you please confirm how Mattermost was installed in the system and what specific action were you performing when the log entry you shared was generated? Were you attempting to activate the Github plugin or something else?

If it is related to the process of activating the plugin, can you confirm if it is also affecting other plugins too? If not, may I know if you have configured the plugin before enabling it?

            "github": {
                "enablecodepreview": "public",
                "enableprivaterepo": null,
                "encryptionkey": null,
                "enterprisebaseurl": null,
                "enterpriseuploadurl": null,
                "githuboauthclientid": null,
                "githuboauthclientsecret": null,
                "githuborg": null,
                "webhooksecret": null
            },

It happens when I save any setting, eg notifications
but yes I was trying to activate Github plugin

I suggest (from a linux command line) changing the file permissions of the config.json file to the 777 permissions, which will doubly make sure that the web server is allowed to make modifications to the file (such as opening and writing to the file, to save new configuration from the system console)

You can do this with the following command:
sudo chmod 777 /opt/mattermost/config/config.json and furthermore, check that you have set the correct file ownership for you server’s instance by changing ownership to the mattermost system user and group that you should have created during the installation process, by running the command
chown mattermost:mattermost /opt/mattermost/config/config.json
Do feel free to change the filepath to the config.json file if you have installed it in another location, I do hope this helps!