Mattermost Peer-to-Peer Forum

Can't get MM to listen on 443


#1

Hey All,

Using Ubuntu Server 18.04. Following the directions in the MM install docs for 18.04 (non container install) to the letter. I can get the server up on port 80 and browse to it. But as soon as I try the procedure of changing the port setting in the MM config.json to 443, setting use letsencrypt to true, turning TLS on, enabling FrowardPort80to443, I simply cannot get the daemon to listen on port 443 on ipv4 (the IP is statically set in the VM if that makes a diff). I see in the docs that it states that in order for the daemon to listen on 443 you need to run the setcap command, but that seems to make little difference, even after a reboot or restart of the MM daemon. From what I can tell the ufw is totally disabled.

Frustrated and thinking the automatic letsencrypt process may be broken for some reason, I made my own certs with the letsencrypt certbot software successfully and set the paths in the MM config.json, but to no avail, same issue. The MM daemon starts, which leads me to believe the config.json is ok, or at least the syntax of it is correct, but nothing starts listening on port 443 when running netstat. When I try to browse to 443 in chrome I get ERR_Connection_Refused, I assume this is becasue nothing is listening on 443.

This is all stock stuff, so I must be missing something simple, any direction here would be appreciated.


#2

Hi @Zavestang,

Do you see any errors in mattermost.log or when you run

sudo service mattermost status

or

sudo journalctl -xe