We're Hiring!

Mattermost, Inc.

Cannot run the 2nd instance with new config.json

I want to run the second MM instance on the same Ubuntu install, so I tried to make the copy of the config.json, then created a new database for it, updated the config.json with new DB URL, when I try to start the server as such

./mattermost --config config2.json

I got this error, did I miss anything? or is this scenario supported?

{“level”:“error”,“ts”:1606716632.363144,“caller”:“sqlstore/supplier.go:906”,“msg”:“Failed to create index”,“error”:“pq: relation “idx_channel_search_txt” does not exist”,“error”:“pq: functions in index expression must be marked IMMUTABLE”}

Hi Sherwoodyao,

Did you follow the instructions in https://docs.mattermost.com/install/install-ubuntu-1804.html#installing-postgresql-database-server for creating the new database?

  1. What version of PostgreSQL are you using?
  2. What is you version of Mattermost?

This information will enable us replicate the issue.

1 Like

Hi Andrew, yes I followed the db install step, actually, I am reusing the same postgresql instance with a new database, and I verified the psql was successful

~$ psql --dbname=mattermost2 --username=mmuser --password
Password for user mmuser:
psql (10.12 (Ubuntu 10.12-0ubuntu0.18.04.1))
Type "help" for help.
mattermost2=> \q

The MM server is 5.28

1 Like

Can I ask if you have setup properly a new web server configuration file with a new virtual host and reverse proxy for your second instance, and can you confirm that you are not running your second Mattermost instance on the same (internal) port as your main instance?