Mattermost, Inc.

Cannot Disable Notifications (Native Client on Windows 10)

Disabling notifications per Account Settings | Notifications does not seem work on Windows 10. See my settings:

I am able to disable the text part of the notification by configuring system notifications (unable to post more than one image because I am a new user, so no screenshot for this…) and I’ve also tried just disabling desktop notifications entirely (setting “Send desktop notifications” to “never”) but the sound still plays no matter what. Mattermost does not show up in the Windows volume mixer so you cannot disable it there either.

It’s driving a couple of my users crazy. The only way I can find to disable sounds in the native Windows client on Windows 10 is to mute speakers.

Please help!

Thanks @Curdie for the report!

You’re correct, this is an underlying issue with the Desktop Apps.

However, there is a fix submitted for the Mattermost Server where turning notification sound off will also disable them for the Desktop App. Mattermost Server 3.5 will be available on November 16.

Fantastic! My users will be glad to hear that a fix is in the works. Thank you!

FYI: I’m experiencing similar situation in Android. Found out the other night when teams that work in a different timezone started tagging me and I got sound notifications in the middle of the night, although my phone was set to silence (silence alerts)

@ngcnelson Can you try if the issue reproduces on the newest Mattermost Android app in the Google Play store?

We made some improvements and bug fixes with the 3.5 release.