Mattermost Peer-to-Peer Forum

Android client Version 1.15.0 - Critical error JavaRuntime Exception


#1

After updating to the latest version I’m greeted by the following message.
This seems like a build error to me, does anyone else have the same problem?
Is this the best forum to lodge a bug?

Mattermost Client Version 1.15.0
Anddroid Version 5.1.1 ( don’t judge :slight_smile: )

Thanks for your help.


#2

Hi @hjj,

Thanks for your report…

I believe you will need to upgrade your Android version as the minimum version required to run Mattermost v1.15 app is Android 7.0

Let us know how it goes after you’ve upgraded your Android version :+1:


#3

Great, updating Android is out of the question.
Now I have to find a previous build.
Wondering why this update installed in the first place when it is incompatible.

Cheers.


#4

@hij We’re looking at taking the following actions:

  1. Cut a new build (164) containing Mattermost 1.14 and deploy it for Android
  2. Cut a build (165) containing 1.15 with the minimum version set correctly, so that the previous Mattermost version is retained for older devices (the new version will only be installed on Android 7+).

Our team is working on these first thing tomorrow morning. Appreciate your report and hope to get this resolved for you soon.


#5

@hjj you should be able to upgrade to a new build in the play store containing v1.14.0. Please let us know if that resolves your issue?

In the future if you end up upgrading your device, you can access versions 1.15.0 and later.

Appreciate your help identifying this issue and getting it resolved


#6

@eric & @jasonblais you guys are better than Santa!

Thanks very much to everyone involved for your quick action on the issue.
The update/downgrade via the Playstore worked as expected.


#7

Thanks for identifying the issue and for the report @hjj :slight_smile:

Glad we could help resolve the issue and things are working as expected for you now!