Mattermost, Inc.

Alert settings different between mobile and desktop

For feature requests, please see: http://www.mattermost.org/feature-requests/.

For troubleshooting questions, please post in the following format:

Summary

Received alerts via email even though I had modified the setting on my phone to never email me.

Steps to reproduce

MM Pre-release server and self-hosted 5.1
Login with new account change email notifications on mobile to NEVER
Wait a bit, check desktop or web app. Change not reflected but mobile still thinks it is. You will get emails for @mentions.

Expected behavior

Mobile setting should properly modify alery settings.

Observed behavior

Mobile:
Screenshot_20180817-085147

Desktop:
Mattermost_2018-08-17_08-52-00

Hi @earlgrei, thank you for reporting this.

I’ll test this out today and I’ll create a ticket if I can reproduce.

Hi @earlgrei, I created a ticket for this here: https://mattermost.atlassian.net/browse/MM-11774. Thanks for finding this bug!

I do try. Makes two I’ve found. Fun times. I do appreciate the responsiveness you folks have as well. Cheers